Compatibility

Sparkle requires Mac OS X 10.9 Mavericks or later and runs smoothly on the latest 10.10 Yosemite, 10.11 El Capitan, 10.12 Sierra and 10.13 High Sierra.

Websites generated with Sparkle have been tested in a variety of scenarios.

Specifically Sparkle websites work on all current versions of the major browsers of each platform:

Safari

Firefox

Microsoft Internet Explorer and Microsoft Edge

Google Chrome

and the mobile browsers:

  • Safari on iOS
  • The Android “Browser” (up to Android 4.x)
  • Google Chrome on Android

Compatibility and visuals are degraded in older versions, but this is very minor for browsers shipped in the past 5 years.

Sparkle has specific provisions and workarounds to make sites work on Internet Explorer back to version 9 with a visual degradation for some features.

Updated for Sparkle 2.6

Auf Deutsch

Please report any shortcoming in this documentation and we’ll fix it as soon as possible!

This site uses cookies. Some are essential to make our site work; others help us improve the user experience and display third party content. By using the site, you agree to our site sending these cookies. Read our privacy policy to learn more or opt out.